Introduction:

UDG1000 Input Driver -SC1000 Modbus TCP_IP
Introduction:

The UDG1000 Modbus TCP Input Driver is used to collect data from a sc1000 Network via Modbus TCP. Any Tag (reading, status, error, etc…) that is configured in the sc1000 telegram can be collected.

MODBUS TCP/IP definition: Modbus TCP/IP is the latest data transmission protocol offered by the MODBUS foundation. By combining MODBUS with TCP/IP, the sc1000 is now able to stream data over an Ethernet physical layer or over the internet using GSM-GPRS.

Copyright 2013 Hach, All rights reserved.


Pre-requisites:

UDG1000 Input Driver -SC1000 Modbus TCP_IP
Pre-requisites:

1. UDG1000 Software is installed on PC.

2. Make sure that the sc1000 firmware version is 3.12 or later. The firmware version is displayed on:

a. The sc1000 web browser login page

b. On the sc1000 display module during startup

3. Make sure that the probes are connected correctly to the sc1000. Make sure that the probe measurement values are shown on the display.

4. Make sure that the optional SC1000 MODBUS TCP license is enabled: From the sc1000 main menu go to SC1000 SETUP>LICENSE MANAGEMENT and verify the MODBUS TCP EXPRIATION DATE is valid.

5. Make sure that the MODBUS TCP connection is set to on: From the sc1000 main menu go to SC1000 SETUP>MODBUS TCP>ON

6. Make sure that the MODBUS TCP TELEGRAM is configured. From the sc1000 main menu go to SC1000 SETUP>MODBUS TCP>TELEGRAM. Add the necessary probe parameters to the telegram and push OK.

7. Make sure that remote control of sc1000 controller is available through dial-up, GPRS (GSM modem) or LAN connection (service port).

a. Open a web browser and enter the IP Address of the sc1000 controller (default 192.168.154,30) in the browser’s address box. Refer to the sc1000 User Manual for more information.

Copyright 2013 Hach, All rights reserved.


Setup

UDG1000 Input Driver -SC1000 Modbus TCP_IP
Setup

1. Add a new collector. From the UDG1000 Main Menu go to Input>Collectors and click Add.

2. Select Modbus TCP/IP from the list. Click Add.

3. Enter a name for the collector. Click Save.

4. Configure the collector.

Option | Description
IP Address | Enter the IP address of the sc1000 controller
Port | Enter the sc1000 Modbus TCP Port. Must match the sc1000 TCP Port: On the SC1000 – Main Menu>SC1000 SETUP>MODBUS TCP>TCP PORT
Slave Address | Enter the sc1000 Modbus Address. Must match the sc1000 Modbus Address On the SC1000 – Main Menu>SC1000 SETUP>MODBUS TCP>MODBUS ADDRESS

5. Click Test Connection. Test Success! shows when the connection is set. Data Order will be detected will be displayed.

6. Click Save.

7. From the UDG1000 Main Menu go to Input>Parameters

8. The Parameters will be auto-detected by interrogating the sc1000 and exposing the Modbus registers in the sc1000 Modbus Telegram

9. Select the Tags to be tracked, click [image] and the Parameters will be created.

a. To select multiple Tags, use Shift-Click and Ctrl-Click

UDG1000 will start to collect data for the parameters. To change a parameters polling rate, Decimal Places or Units click on the Parameter and click Edit…

Copyright 2013 Hach, All rights reserved.