Introduction:

OPC DA v2/3 Input Driver User Manual
Introduction:

The UDG1000 OPC DA V2/3 Input Driver is used to collect data from an OPC DA Server (version 2.x, 3.x). OLE for Process Control is a communication standard developed by the OPC Foundation®. OPC uses Microsoft COM/DCOM technology to send Process Control messages between programs.

Fundamentally, OPC is comprised of two parts, servers and clients. Servers translate data from hardware devices and convert the data to a standard format called Tags. Each tag represents a piece of data such as a sensor reading, an alarm state, or a status value. The second part, clients, connects to servers and uses the OPC tags.

Copyrigh 2013 Hach, All rights reserved.


Pre-requisites:

OPC DA v2/3 Input Driver User Manual
Pre-requisites:

1. UDG1000 Software is installed on PC.

2. Access to an OPC DA Server version 2 or 3. Note: It is strongly recommended to access OPC DA Servers on the same computer as UDG1000 is installed. Accessing OPC DA Servers over a network is difficult as many security issues need to be addressed. If you cannot install UDG1000 on the same computer as the OPC DA server, see http://www.opssys.com/instantkb/article.aspx?id=10834 for information on how to enable communication (DCOM) over the network.

Copyrigh 2013 Hach, All rights reserved.


Setup

OPC DA v2/3 Input Driver User Manual
Setup

1. Add a new collector. From the UDG1000 Main Menu go to Input>Collectors and click Add.

2. Select “OPC DA V2/3” from the list. Click Add.

3. Enter a name for the collector. Click Save.

4. Configure the collector. Click Save.

Option | Description
OPC DA Server | Select from the list of registered OPC DA Servers available. Note: When an OPC Server is installed, it registers itself in the Windows Registry.

5. From the UDG1000 Main Menu go to Input>Parameters

6. The Parameters/Tags for the OPC DA Server will be auto-detected

7. Select the Tags to be tracked, click [image] and the Parameters will be created.

a. To select multiple Tags, use Shift-Click and Ctrl-Click

UDG1000 will start to collect data for the parameters. To change a parameters polling rate, Decimal Places or Units click on the Parameter and click Edit…

Copyrigh 2013 Hach, All rights reserved.