Introduction:

UDG 1000 Modbus RTU/ASCII (sc100-sc200-sc1000) Input Driver
Introduction:

The UDG1000 Modbus/ASCII RTU Input Driver is used to collect data from a sc100/sc200/sc1000 Network via Modbus RTU.

Copyrigh 2013 Hach, All rights reserved.


Pre-requisites:

UDG 1000 Modbus RTU/ASCII (sc100-sc200-sc1000) Input Driver
Pre-requisites:

1. UDG1000 Software is installed on PC.

2. Modbus expansion module for each controller.

a. For SC200 - MODBUS RS232/485 Communication Module for sc200 Universal Controller (Hach Product# 9013200) is installed.

b. For SC1000 - Modbus RS485 internal plug-in expansion card (Hach Product# YAB021). Note only one sc1000 controller needs to have the Modbus card on a sc1000 network (i.e. multiple sc1000 probe modules daisy chained via Internal network connector (LZX918) and sc1000 BUS Cable (Product #: LZY488) )

c. For sc100 – need sc100 Controller with RS-485 (Modbus). Product Number LXV401.52.02002 (Obsolete)

3. Modbus network connected to Serial Port of PC or to USB port via Hach RS485 to USB Converter Kit (Hach Product # 5920400, AKA ULINK)

4. Make sure that the probes are connected correctly to the sc. Make sure that the probe measurement values are shown on the display.

5. sc Network is setup. On sc200, go to Settings>Network and verify setup. See sc200 Modbus Module User Manual for more information.

Copyrigh 2013 Hach, All rights reserved.


Setup

UDG 1000 Modbus RTU/ASCII (sc100-sc200-sc1000) Input Driver
Setup

1. Add a new collector. From the UDG1000 Main Menu go to Input>Collectors and click Add.

2. Select “Modbus RTU/ASCII” from the list. Click Add.

3. Enter a name for the collector. Click Save.

4. Configure the collector.

Option | Description
Serial Port | Enter the PC’s serial port (COM1, COM2,etc…) that the Modbus is connected to. Drop down displays available serial ports on the PC.
Baud Rate: | The Baud rate—Rate (bits per second) at which the data is transmitted across the network. All devices (PC, SC controllers) on a network must be set to the same Baud rate. The desired setting will depend on the physical layout of the network. Degrees of speed options—9600, 19200 (Default setting), 38.4K, 57.6K, 115.2K For the sc200 must match the Settings>Network - Baud Rate Setting
Mode | Enter the Modbus mode – RTU (Default) or ASCII. All devices on a network must be set to the same mode.
Parity | None (Default), Even, or Odd. All devices (PC, SC controllers) on a network must be set to the same Parity.
Stop Bits | 1 (Default) or 2. All devices (PC, SC controllers) on a network must be set to the same Stop Bits.
Swap Registers | Must match the SC controllers Data Order setting. DO NOT CHECK if SC is set to “Little Endian” (default). Check setting if SC Controller is set to “Big Endian”

5. You must add each Probe on the network to the Probe table. Click [image] to choose from a list of Probes and their Slave Address (Modbus Address set for Probe on the SC200/SC100):

1. Click

2. Click

3. Choose the Probe.

4. Set the Slave Address. This can be found on the SC200 under Menu>Settings>Network>Modbus. Your Modbus devices will be listed with their corresponding slave address to the right.

5. Click Save. The Probe will be displayed in the Collector Configuration, Probe list.

6. Click Save at the bottom of the Collector Configuration to save the settings and Probes.

7. From the UDG1000 Main Menu go to Input>Parameters

8. The Parameters for the listed probes will be auto-detected

9. Select the Tags to be tracked, click [image] and the Parameters will be created.

a. To select multiple Tags, use Shift-Click and Ctrl-Click

UDG1000 will start to collect data for the parameters. To change a parameters polling rate, Decimal Places or Units click on the Parameter and click Edit…

Copyrigh 2013 Hach, All rights reserved.