Home : Products : OPS SQL : Upgrading OPS SQL Clients on Citrix
Q10041 - INFO: Upgrading OPS SQL Clients on Citrix

Applying OPS SQL Client self-upgrades can be a little bit tricky on Citrix. The problem is that the self-upgrade needs to overwrite OPSSQL.exe. If there are multiple users in Citrix running OPSSQL.exe at the time when the 'Minimum Client version to Login' setting is raised, the self-upgrade procedure will most likely fail. The error message will look similar to this :

Error #75 means that OPSSQL.exe cannot be overwritten because it is being executed by one or more users on the current server.

THE FIX :
You will need to kick all users connected to OPSSQL.exe off the current Citrix server. Then run clientup.exe which will force self-upgrade to the lastest available version.

PLEASE NOTE :
It is very common to run OPSSQL.exe on multiple load-balanced Citrix servers. If this is the case, the upgrade has to be applied to each server before the application use is resumed.

Related Articles
No Related Articles Available.

Article Attachments
No Attachments Available.

Related External Links
No Related Links Available.
Help us improve this article...
What did you think of this article?

poor 
1
2
3
4
5
6
7
8
9
10

 excellent
Tell us why you rated the content this way. (optional)
 
Approved Comments...
No user comments available for this article.
Created on 3/30/2004 11:21 AM.
Last Modified on 9/18/2007 5:36 PM.
Last Modified by No Author Name Available!.
Article has been viewed 5584 times.
Rated 5 out of 10 based on 4 votes.
Print Article
Email Article