Home : Which MS SQL Express database should be installed
Q14198 - INFO: Which MS SQL Express database should be installed

As of May 2014, Hach WIMS Multiuser utilizes MS SQL 2012 Express DBMS which allows 10 GB's of data space for each facility. 

MS SQL 2012 Express can only be installed on:

  • Windows Server 2012 R2, Windows Server 2012, Windows Server 2008 R2 Service Pack 1 (SP1), Windows Server 2008 Service Pack 2 (SP2), Windows 8.1, Windows 8, Windows 7 Service Pack 1 (SP1).


The following operating systems are not supported by MS SQL 2012: Windows Vista, Windows XP, Windows Server 2003 and Windows Server 2000.   If you are installing the Server Components on a PC running one of these Operating Systems the installer will install MS SQL 2005 Express instead of MS SQL 2012 Express.

MS SQL 2005 Express can only support databases up to 4GB, therefore it is recommended that you install the Server Components on a PC with an OS that supports MS SQL 2012.  If one is not available, MS SQL 2005 Express still works with Hach WIMS you are just limited to 4 GB of data per facility database.  (A resource to view MS SQL Express size limits: http://help.acctivate.com/articles/4047/)

NOTE: If you are running your own DBMS (SQL Server or Oracle) you need DB Support in your WIMS License and this article does not apply to you.


Do all computers running Hach WIMS need to be Windows 7 or later?

No.  Only the PC where the DBMS (MS SQL 2012 Express) is installed.  The client software, WIMS Services and interfaces can be installed on any PC running Windows XP or later.  See Hach WIMS Software Requirements.

Can I upgrade at a later date?

Yes if you are using a Windows operating system that will support newer Microsoft database mangement systems (DBMS).  If you upgrade the OS on the PC where your MS SQL 2005 Express DBMS is installed, you can do an in-place upgrade to MS SQL 2012. See How to upgrade to MS SQL 2012 Express from MS SQL 2005

Can I upgrade to MS SQL 2012 Express?

Yes, if you are using a Windows operating system that will support newer Microsoft database mangement systems (DBMS). Windows XP will only support MS SQL 2005 Express, so this will not work. You will need Windows 7 Operating System or higher.

 
Related Articles
No Related Articles Available.

Article Attachments
No Attachments Available.

Related External Links
No Related Links Available.
Help us improve this article...
What did you think of this article?

poor 
1
2
3
4
5
6
7
8
9
10

 excellent
Tell us why you rated the content this way. (optional)
 
Approved Comments...
No user comments available for this article.
Created on 4/7/2014 3:04 PM.
Last Modified on 7/23/2014 4:09 PM.
Last Modified by No Author Name Available!.
Article has been viewed 1910 times.
Rated 3 out of 10 based on 1 vote.
Print Article
Email Article